GBodyCentral.com  
  #1  
Old 06-26-2017, 03:13 PM
jason.newton's Avatar
jason.newton jason.newton is offline
FNG
 
Join Date: Oct 2015
Posts: 9
Default Drum Brakes 84 El camino

Hey Folks I got a question from me not recognizing a bone headed thing I did, I pulled into a rent all place today and the parking is on a incline in which I set Emergency Parking Brake. apparently my brake dummy light doesn't work, thats 1 issue I'm not concerned about quit yet, backing down and out the inclined parking lot, the set brakes had no indication it was set had no problem in the reverse direction off hill and torque to back out and all the way of a mile to my destination before i realized my fubar, when I got to my destination, I could definitely smell hot stinch of pad or something. I noticed during a small test going back home how well it engaged going 20mph and it easily locked up the rear wheels meaning they work and was engaged during that mile trip. Question.... Glazed the brake pads, or ruined​ them I guess the only way of knowing is to start taking things apart. Now back to the dummy light if it worked my common sense Hopefully would have kicked in and noticed Red Light Hey... look at me. I never recall any drag from the rear emergency brakes when I made that little jont. Im just worried about what damage I did. That can't be good on the tranny as well it's the weak metric 200c or 250c. Later everyone, Live and learn.

Sent from my E6810 using Tapatalk
Reply With Quote
  #2  
Old 06-26-2017, 05:01 PM
melloelky melloelky is offline
Hot Rodder
 
Join Date: Aug 2010
Location: boston,mass
Posts: 920

Default

yea they got kinda warm but the brakes still worked on the way home you're fine.
Reply With Quote
  #3  
Old 06-26-2017, 05:20 PM
Poltergeist's Avatar
Poltergeist Poltergeist is offline
Just a ghost in the machine
 
Join Date: Aug 2010
Location: Ontario, Calif.
Posts: 2,730

Default

Here is a link to the electrical drawing that has the parking brake switch that should have lit the brake light.

http://www.gbodycentral.com/forums/e...ghts-large.png
__________________
1982 El Camino (Original owner)
LT1 from a '95 Impala
A bunch of other stuff check out my Garage
Reply With Quote
  #4  
Old 06-27-2017, 11:23 AM
jason.newton's Avatar
jason.newton jason.newton is offline
FNG
 
Join Date: Oct 2015
Posts: 9
Default

I honestly think it's a burnt out brake light bulb, I've been inside the console a few times so I could look/ diagnose... The ride into work this morning, the braking felt normal, I may never feel better until I look inside the drum area and have a looksy though, Thanks folks.

Sent from my E6810 using Tapatalk
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 07:26 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
vB.Sponsors