GBodyCentral.com  
  #1  
Old 09-24-2015, 09:42 AM
HuntN4Meat's Avatar
HuntN4Meat HuntN4Meat is offline
FNG
 
Join Date: Sep 2015
Location: Petaluma, Ca.
Posts: 2
Default ECM Knock Sensor

I have a 1984 El Camino with an engine swap done 305cu in/? HP to a Jegs 355/400+ HP. Runs like it's in "Limp Mode". Rewired completely as a "Tweeker" had wire cutters and relays??? I have removed and either replaced or repaired the Engine bay, Lighting, ECM & Complete Dash Wiring back to factory specs + Added power Locks & Windows. Engine has NEW carb, plugs, cap, rotor, PCV & O2 sensor. Have done a lot of research into the "Knock Sensor" and the GM Wiring diagram I have DOES NOT show any such sensor or wiring for it. I have had the wiring harness out of the vehicle (Yes fenders were off) and on the bench and can find no cut missing wires.

Still need to find out about Knock Sensor. My ECM has these markings;

DKZ
*861861 46841577

Service
Number 16041861
Lit Ref Code 1226455

Wires coming from the EST are as follows on both the diagram and physically (except B could be purple or pink);
A = White to Spark Timing Output 423
B = Pink w/White Strip to Dist Ref Pulse Hi Input 430
C = Tan w/Black Strip to Ign Mod Bypass Output 424
D = Black w/Red Strip to Dist Ref Pulse Lo Input 453

Nothing on the wiring diagram about "Knock Sensor"

If it needs one where does it connect and what color wire?
Runs like it's in "Limp Mode" help!

Give me "Old School" anytime!!!

Thanks
Jim
Reply With Quote
  #2  
Old 09-24-2015, 02:13 PM
Poltergeist's Avatar
Poltergeist Poltergeist is offline
Just a ghost in the machine
 
Join Date: Aug 2010
Location: Ontario, Calif.
Posts: 2,744

Default

I don't see a knock sensor on the drawing I have here.

http://www.gbodycentral.com/forums/e...s-V8-large.png

I don't remember which pins, but on the diagnostic plug you can short 2 of them together and your check engine light will flash the trouble code. For that matter is your check engine light lit?
__________________
1982 El Camino (Original owner)
LT1 from a '95 Impala
A bunch of other stuff check out my Garage
Reply With Quote
  #3  
Old 09-24-2015, 05:04 PM
HuntN4Meat's Avatar
HuntN4Meat HuntN4Meat is offline
FNG
 
Join Date: Sep 2015
Location: Petaluma, Ca.
Posts: 2
Default Check Engine light

No light when key is on or engine running?
Reply With Quote
  #4  
Old 09-24-2015, 06:42 PM
Poltergeist's Avatar
Poltergeist Poltergeist is offline
Just a ghost in the machine
 
Join Date: Aug 2010
Location: Ontario, Calif.
Posts: 2,744

Default

Sounds like the engine is running right as far as the ECU is concerned. What is it doing that you think it is in limp mode?
__________________
1982 El Camino (Original owner)
LT1 from a '95 Impala
A bunch of other stuff check out my Garage
Reply With Quote
Reply

Tags
electrical, engine swap, knock sensor, smog


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 01:53 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
vB.Sponsors